Problems Installing V1.0

Topics: Developer Forum, Project Management Forum, User Forum
Sep 20, 2007 at 7:47 PM
We are currently using V0.3 with no issues, but have had difficulty installing the latest release. Here is the relevant part of the log.

identity="$$PROJECTNAME$$\Build Services" />
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | Allowing permission(s) Read, PendChange, Checkin, Label, Lock to group []\Build Services
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | <checkin_note label="Code Reviewer" required="false" order="1" />
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | Creating check-in note - label="Code Reviewer" required="False" order="1"
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | <checkin_note label="Security Reviewer" required="false" order="2" />
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | Creating check-in note - label="Security Reviewer" required="False" order="2"
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | <checkin_note label="Performance Reviewer" required="false" order="3" />
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | Creating check-in note - label="Performance Reviewer" required="False" order="3"
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | Changing project setting ExclusiveCheckout to "False"
2007-09-20 11:40:10Z | Module: Engine | Task "VersionControlTask" from Group "VersionControl" completed with success | Completion time: 0.015625 seconds
2007-09-20 11:40:10Z | Module: Engine | Thread: 5 | Running Task "" from Group ""
2007-09-20 11:40:10Z | Module: Engine | Thread: 5 | Running Task "SharePointPortal" from Group "Portal"
2007-09-20 11:40:10Z | Module: WSS | Thread: 5 | Language id: 1033
2007-09-20 11:40:10Z | Module: WSS | Thread: 5 | Verifying site template exists on the server using http://wbsqlserver1/vtibin/Sites.asmx
---begin Exception entry---
Time: 2007-09-20 11:40:11Z
Module: Engine
Event Description: TF30162: Task "SharePointPortal" from Group "Portal" failed
Exception Type: Microsoft.TeamFoundation.Client.PcwException
Exception Message: TF30272: Template not found on the server
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.VerifySiteTemplate(ProjectCreationContext context, String template, Int32 lcid)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.ValidateSite(ProjectCreationContext context, XmlNode site)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Validate(ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.TaskValidator.PerformTask(IProjectComponentCreator componentCreator, ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.RunTask(Object taskObj)
--- end Exception entry ---

2007-09-20 11:40:11Z | Module: Engine | Thread: 5 | TF30202: Task "" from Group "" will not be run because a prior task failed.
2007-09-20 11:40:11Z | Module: Engine | Thread: 5 | TF30202: Task "Site" from Group "Reporting" will not be run because a prior task failed.
2007-09-20 11:40:11Z | Module: Engine | Thread: 5 | TF30202: Task "Populate Reports" from Group "Reporting" will not be run because a prior task failed.
2007-09-20 11:40:11Z | Module: Engine | Thread: 5 | TF30202: Task "" from Group "" will not be run because a prior task failed.
---begin Exception entry---
Time: 2007-09-20 11:40:11Z
Module: Template Importer
Exception Type: Microsoft.TeamFoundation.Client.ValidationFailedException
Exception Message: TF30175: Process template validation failed
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.EngineStarter.ValidateTemplate(DirectoryInfo templateDirectory)
at Microsoft.VisualStudio.TeamFoundation.TemplateManagementService.ValidateMethodology(String folderPath, ILogHandler logHandler)
at Microsoft.VisualStudio.TeamFoundation.TemplateManagementService.Import(String folderPath, ILogHandler logHandler)
-- Inner Exception --
Exception Type: Microsoft.VisualStudio.TeamFoundation.TaskFailedException
Exception Message: TF30162: Task "SharePointPortal" from Group "Portal" failed
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.PerformAllTasks(ITaskPerformer taskPerformer, ProjectCreationContext creationContext, List`1 projectTasks)
at Microsoft.VisualStudio.TeamFoundation.EngineStarter.RunEngine(Boolean isValidationRun, String templateFolder)
at Microsoft.VisualStudio.TeamFoundation.EngineStarter.ValidateTemplate(DirectoryInfo templateDirectory)
-- end Inner Exception --
-- Inner Exception --
Exception Type: Microsoft.TeamFoundation.Client.PcwException
Exception Message: TF30272: Template not found on the server
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.VerifySiteTemplate(ProjectCreationContext context, String template, Int32 lcid)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.ValidateSite(ProjectCreationContext context, XmlNode site)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Validate(ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.TaskValidator.PerformTask(IProjectComponentCreator componentCreator, ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.RunTask(Object taskObj)
-- end Inner Exception --
--- end Exception entry ---

Coordinator
Sep 25, 2007 at 9:27 PM
Are you installing on v01 or Orcas? There is a sharepoint issue with Orcas.


sammamish2001 wrote:
We are currently using V0.3 with no issues, but have had difficulty installing the latest release. Here is the relevant part of the log.

identity="$$PROJECTNAME$$\Build Services" />
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | Allowing permission(s) Read, PendChange, Checkin, Label, Lock to group []\Build Services
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | <checkin_note label="Code Reviewer" required="false" order="1" />
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | Creating check-in note - label="Code Reviewer" required="False" order="1"
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | <checkin_note label="Security Reviewer" required="false" order="2" />
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | Creating check-in note - label="Security Reviewer" required="False" order="2"
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | <checkin_note label="Performance Reviewer" required="false" order="3" />
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | Creating check-in note - label="Performance Reviewer" required="False" order="3"
2007-09-20 11:40:10Z | Module: SccTask | Thread: 5 | Changing project setting ExclusiveCheckout to "False"
2007-09-20 11:40:10Z | Module: Engine | Task "VersionControlTask" from Group "VersionControl" completed with success | Completion time: 0.015625 seconds
2007-09-20 11:40:10Z | Module: Engine | Thread: 5 | Running Task "" from Group ""
2007-09-20 11:40:10Z | Module: Engine | Thread: 5 | Running Task "SharePointPortal" from Group "Portal"
2007-09-20 11:40:10Z | Module: WSS | Thread: 5 | Language id: 1033
2007-09-20 11:40:10Z | Module: WSS | Thread: 5 | Verifying site template exists on the server using http://wbsqlserver1/vtibin/Sites.asmx
---begin Exception entry---
Time: 2007-09-20 11:40:11Z
Module: Engine
Event Description: TF30162: Task "SharePointPortal" from Group "Portal" failed
Exception Type: Microsoft.TeamFoundation.Client.PcwException
Exception Message: TF30272: Template not found on the server
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.VerifySiteTemplate(ProjectCreationContext context, String template, Int32 lcid)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.ValidateSite(ProjectCreationContext context, XmlNode site)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Validate(ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.TaskValidator.PerformTask(IProjectComponentCreator componentCreator, ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.RunTask(Object taskObj)
--- end Exception entry ---

2007-09-20 11:40:11Z | Module: Engine | Thread: 5 | TF30202: Task "" from Group "" will not be run because a prior task failed.
2007-09-20 11:40:11Z | Module: Engine | Thread: 5 | TF30202: Task "Site" from Group "Reporting" will not be run because a prior task failed.
2007-09-20 11:40:11Z | Module: Engine | Thread: 5 | TF30202: Task "Populate Reports" from Group "Reporting" will not be run because a prior task failed.
2007-09-20 11:40:11Z | Module: Engine | Thread: 5 | TF30202: Task "" from Group "" will not be run because a prior task failed.
---begin Exception entry---
Time: 2007-09-20 11:40:11Z
Module: Template Importer
Exception Type: Microsoft.TeamFoundation.Client.ValidationFailedException
Exception Message: TF30175: Process template validation failed
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.EngineStarter.ValidateTemplate(DirectoryInfo templateDirectory)
at Microsoft.VisualStudio.TeamFoundation.TemplateManagementService.ValidateMethodology(String folderPath, ILogHandler logHandler)
at Microsoft.VisualStudio.TeamFoundation.TemplateManagementService.Import(String folderPath, ILogHandler logHandler)
-- Inner Exception --
Exception Type: Microsoft.VisualStudio.TeamFoundation.TaskFailedException
Exception Message: TF30162: Task "SharePointPortal" from Group "Portal" failed
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.PerformAllTasks(ITaskPerformer taskPerformer, ProjectCreationContext creationContext, List`1 projectTasks)
at Microsoft.VisualStudio.TeamFoundation.EngineStarter.RunEngine(Boolean isValidationRun, String templateFolder)
at Microsoft.VisualStudio.TeamFoundation.EngineStarter.ValidateTemplate(DirectoryInfo templateDirectory)
-- end Inner Exception --
-- Inner Exception --
Exception Type: Microsoft.TeamFoundation.Client.PcwException
Exception Message: TF30272: Template not found on the server
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.VerifySiteTemplate(ProjectCreationContext context, String template, Int32 lcid)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.ValidateSite(ProjectCreationContext context, XmlNode site)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Validate(ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.TaskValidator.PerformTask(IProjectComponentCreator componentCreator, ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.RunTask(Object taskObj)
-- end Inner Exception --
--- end Exception entry ---



Oct 10, 2007 at 8:27 PM
Edited Oct 10, 2007 at 8:27 PM
I am not using ORCAS and have the same results, v.0.3 works fine, but cannot upload v1.0 without error.

2007-10-10 14:17:12Z | Module: WSS | Thread: 8 | Verifying site template exists on the server using http://teamsystem/vtibin/Sites.asmx
---begin Exception entry---
Time: 2007-10-10 14:17:13Z
Module: Engine
Event Description: TF30162: Task "SharePointPortal" from Group "Portal" failed
Exception Type: Microsoft.TeamFoundation.Client.PcwException
Exception Message: TF30272: Template not found on the server
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.VerifySiteTemplate(ProjectCreationContext context, String template, Int32 lcid)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.ValidateSite(ProjectCreationContext context, XmlNode site)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Validate(ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.TaskValidator.PerformTask(IProjectComponentCreator componentCreator, ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.RunTask(Object taskObj)
--- end Exception entry ---

2007-10-10 14:17:13Z | Module: Engine | Thread: 8 | TF30202: Task "" from Group "" will not be run because a prior task failed.
2007-10-10 14:17:13Z | Module: Engine | Thread: 8 | TF30202: Task "Site" from Group "Reporting" will not be run because a prior task failed.
2007-10-10 14:17:13Z | Module: Engine | Thread: 8 | TF30202: Task "Populate Reports" from Group "Reporting" will not be run because a prior task failed.
2007-10-10 14:17:13Z | Module: Engine | Thread: 8 | TF30202: Task "" from Group "" will not be run because a prior task failed.
---begin Exception entry---
Time: 2007-10-10 14:17:13Z
Module: Template Importer
Exception Type: Microsoft.TeamFoundation.Client.ValidationFailedException
Exception Message: TF30175: Process template validation failed
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.EngineStarter.ValidateTemplate(DirectoryInfo templateDirectory)
at Microsoft.VisualStudio.TeamFoundation.TemplateManagementService.ValidateMethodology(String folderPath, ILogHandler logHandler)
at Microsoft.VisualStudio.TeamFoundation.TemplateManagementService.Import(String folderPath, ILogHandler logHandler)
-- Inner Exception --
Exception Type: Microsoft.VisualStudio.TeamFoundation.TaskFailedException
Exception Message: TF30162: Task "SharePointPortal" from Group "Portal" failed
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.PerformAllTasks(ITaskPerformer taskPerformer, ProjectCreationContext creationContext, List`1 projectTasks)
at Microsoft.VisualStudio.TeamFoundation.EngineStarter.RunEngine(Boolean isValidationRun, String templateFolder)
at Microsoft.VisualStudio.TeamFoundation.EngineStarter.ValidateTemplate(DirectoryInfo templateDirectory)
-- end Inner Exception --
-- Inner Exception --
Exception Type: Microsoft.TeamFoundation.Client.PcwException
Exception Message: TF30272: Template not found on the server
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.VerifySiteTemplate(ProjectCreationContext context, String template, Int32 lcid)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.ValidateSite(ProjectCreationContext context, XmlNode site)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Validate(ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.TaskValidator.PerformTask(IProjectComponentCreator componentCreator, ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.RunTask(Object taskObj)
-- end Inner Exception --
--- end Exception entry ---

Oct 10, 2007 at 9:49 PM
Sorry, I didn't back to this earlier. We actually passed on this template. The business got antsy and decided to go with MSF for Agile. BTW, we aren't using Orcas yet.
Coordinator
Oct 15, 2007 at 2:55 AM
It looks like you may not have uploaded the stp file to share point. Look in the readme file and follow the instructions for uploading the template.
Jun 28, 2008 at 11:15 AM


mazocar wrote:
It looks like you may not have uploaded the stp file to share point. Look in the readme file and follow the instructions for uploading the template.



I'm having the exact same problem too with the v1.0 release. I have uploaded the .stp file using stsadm. Is there any newer release for TFS 2005 than v1.0? The other releases are for TFS 2008 I assume?
Coordinator
Jun 28, 2008 at 3:32 PM
Edited Jun 28, 2008 at 3:37 PM

Can you run the following command and post the results?

stsadm.exe -o enumtemplates (if that command doesn't work you might need another switch or two)

You should see a template named "LightWeightScrum". 

Jun 29, 2008 at 9:53 AM


mazocar wrote:

Can you run the following command and post the results?

stsadm.exe -o enumtemplates (if that command doesn't work you might need another switch or two)

You should see a template named "LightWeightScrum". 




I ran that command, the the template showed up on the list, but I found the problem. SharePoint seems to be case sensitive regarding the template names. My template name was "LightweightScrum", not "LightWeightScrum". I deleted the "LightweighScrum" template and uploaded it again with the correct casing, and now I got the process template uploaded also without errors. I also created a new team project with the scrum template and everything seems to work now.

It might be a good idea to add a note the the readme.txt file that the template title really is case sensitive.
Coordinator
Jun 29, 2008 at 4:09 PM

Glad you got it sorted!  I would not have thought about case and will add that to the readme.

I have wanted to create an installer for the SharePoint stuff for a while.  Maybe we'll get it for the next release.

M